.ENV file in https://replit.com/

Does anyone know how to go about creating a .env file in https://replit.com/

They have changed the site so you can not create a .env so how do I get around this?

Cheers!

Hello there,

There is a symbol which looks like a lock:

Add the variable key (name), and value there.

Hope this helps

Thanks for that but I think I’ve tried that:

Screenshot 2021-04-16 at 13.11.48

The issue is none of your data is within the /json route handler function.

Here are the instructions:

Then, in the GET /json route handler that you created in the last challenge, transform the response object’s message to uppercase if process.env.MESSAGE_STYLE equals uppercase .

Hope this clarifies

Hello @Sky020,

Thanks for the help. I am still stuck on this one.

Logic:

Output:
Screenshot 2021-04-22 at 07.29.14

Testing on FCC

Me right now:

Thanks again for your help!

you have the wrong message, it’s Hello json - consult previous challenge for confirmation

Hey @ilenia thanks for that, OK just changed it and still fails the test?!

I’ve tried on https://replit.com/ and on heroku app too and both fail. I’m lost?!

what’s your code now?
can you post a link to the repl?

Hey can you see my repl here:
https://boilerplate-express.freecodecampdev.repl.co
Thanks!

Also here:
https://boilerplate-express.freecodecampdev.repl.co/json

And you’ll be needing this I guess:

Whattt? OMG I am going nuts. Mine doesn’t pass. I will log out of FCC and back in again then.

I get this - is this the URL you used?

use the url to the app, not to the endpoint

1 Like

Thank you very much! The ‘You’re unstoppable!’ is kinda funny as this has stopped me from making progress for several days! Thanks again :slight_smile:

Please close when you’re happy to!

1 Like

Hello dude! Could you, please, share you link which got qualified for this task? I am stuck at this for a few hours and still can’t figure out the problem. I read the previous comments and wrote the URL without /json part, but still doesn’t work :frowning:

why don’t you create your own topic to ask for help?

1 Like

I got exactly the same code as above, but still have no idea what’s wrong…