FCC not loading in Safari

I’m trying to get to https://www.freecodecamp.org/learn but I just the loader animation. Also there is a left-to-right bar animating in the top right of the title bar.

I’ve tried clearing my cache, cookies and local storage and disabling all Safari Extensions. That lets me log in again, but then I get the same problem with just the loader animation showing and not the curriculum.

I’ve tried logging in using both GitHub authentication and the email code, but the problem persists.

If I use Firefox on the same computer everything works fine, but I prefer to use Safari.

Any ideas?

1 Like

Just to add to this, the problem is identical on two different machines, both running Safari Version 14.0.3 on Mojave.

I’ve tried email, GitHub and Google login. I even created a new account with a different email address. Result is the same.

I’m having the same issue on chrome. Just getting those loading bars but it will not advance. Now knowing I’m not the only one having the issue confirms it’s something I can’t fix myself.

I’m also using chrome @Codefunstuff But it works perfect for me

1 Like

@patthedog I am having the same issue on Safari.
I am carrying on with my exercises in Firefox for now where it works fine.
I also tried all of the above like you did and it is not something we can fix I think.

I am trying to carry on with the exercises however it doesn’t load properly and non of my progress either.
The login sign has also disappeared and it doesn’t seem to be working as it was previously.

It only works in Firefox.

I’ve merged the two topics to have everything in one place, so that the dev team will not have to look at multiple topics

1 Like

Thank you. I tried to do it as well but I couldn’t find how to merge them.

only mods can merge topics

1 Like

Welcome, there.

Would you mind helping debug, by doing the following:

  1. Open browser dev tools
  2. Navigate to the browser console tab
  3. Refresh the page (freeCodeCamp.org)
  4. Look for any errors in the console

Report back here with any results.

Thanks for taking a look at this. Here is what I’m seeing in the browser console.

Same here.

Thank you. Would you mind expanding that red error message, and sharing the extra info?

This is what it looks like. If I click on the anonymous function it crashes after it takes me to the source.

Right. The main thing I am looking for is the column number of the error from line 2. Typically, this would be given in the error information. As the code is minified, line two consists of hundreds of thousands of characters. So, without the column number it is like looking for a needle in the haystack. It is odd that it crashes for you.

Aside from one comment above, this appears to be a Safari-related bug (which I cannot test on). Do you have Chrome/Edge/Firefox to continue on?

Actually, this looks like my fault :man_facepalming:

1 Like

Is it fixable?
I do have Firefox but there it works fine.

It looks like the lookbehind needs to be replaced with less elegant code :frowning: . But yes, fixable from fCC’s side.

1 Like

Okay. Thanks for looking into it mate. :smiley:
@Sky020 isn’t possible to go to the previous version of the site? I mean like undo the change you made

Hey everyone.

Thanks for your patience. We have a fix ready and are currently confirming that it will hold. Can someone here give us feedback by testing the fix on our staging site?

If all looks good, we will roll it forward to the production.

Thanks.

2 Likes