Fedora linux not able to connect to the internet

I thought installing Linux on my laptop would make it faster, or well, at least make the experience faster, it did. But Windows 10 was better in connecting to the internet. And that is the only problem I have with Linux
Everything else is just fine and smooth.
Distro :- Fedora 32(latest)
Boot :- Yes (Single)

you may have better luck with a linux support forum

Hello!

Are you connecting through wifi or ethernet cable? If wifi, does it show you the wifi icon or does it scan the networks?

Wifi. It shows the symbol. But I am not able to connect to the internet. I was good with windows 10😢.

But why can’t you? I mean, does it show an error (wrong password, for instance)? Did you try to connect using the (WPS) button on your router? (Push the WPS button on your router while trying to connect to your access point).

Check the error log for any error related to NetworkManager: systemctl status NetworkManager should display: Active: active (running).

You can check the entire error log: journalctl -e

It shows that I’m connected. I think my laptop is just old to connect via wi-fi.
The story :-
Our tv broke and we had to buy a new one(A smart one), it was “hdmi connected” with the old laptop, and was near the wifi-router and was connected to the internet via the ethernet port, it was running windows 10(Laggy) .
We bought a tv and then I use the old laptop as my secondary device, now the laptop has been moved to my room, and the funny thing is that I installed Linux on it that time. So I got it, it is because it is far away from the router. And the laptop is about 6-8 years old and also not the flagship of the time. Thanks!

1 Like

I have xubuntu on a 12 years old laptop, and it connects fine.

Your computer may be too far away from the router… if you go nearer, does it work?

1 Like

Yes, that’s how I got to know that was the problem. Yes it connect pretty fast when it is near

1 Like

Now that you know the problem, there are some options:

  • Buy a cheap repeater and put it near your new laptop’s location.
  • Use an ethernet cable (this is the best option, IMO).
  • If you have a smartphone that has a good signal in your room, you could use that to connect your computer to (set it as hot-spot and connect the phone to the computer using USB). This may be the cheapest option.
  • Purchase a USB wifi adapter.

I hope it helps :slight_smile:.