Feedback Request for Tribute Page! Constructive Criticism pls

I’ve started my tribute page today and I’ve gotten quite a bit done. I’d like some feedback to ensure I’m on the right track. I also noticed when I started coding the test button went away. Not sure what’s going on there but I can’t test my code. Anyone else have that issue?

Here’s the link to my tribute page. Constructive criticism is greatly appreciated. Thank you!

h t t p s : / / c o d e p e n . i o / O l l i e _ B o l l i e / p e n / w Z p R P g

Post your link with some spaces like;
http://codepen io/ollie/pen/whYIn

or just leave off the protocol

Here’s the link to my tribute page. Constructive criticism is greatly appreciated. Thank you!

h t t p s : / / c o d e p e n . i o / O l l i e _ B o l l i e / p e n / w Z p R P g

Hi there.

Good job so far! I just suggest that you pay more attention to indentation so that it shows clearer hierarchy of code lines. For that I recommend using a separate offline code editor like VSCode or Atom.

Another point about the test button. I used to wonder the same thing and I did some search. It turns out that you have to paste this code at the end of your html:
<script src="https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js"></script>

Keep working!
Hope to see your final result soon :wink:

Thank you, I just figured that out. I pasted the code in there and it’s back. But I’ve failed all the tests and I’m not sure why.

codepen expects you to put in everything that you’d put between the <body> </body> tags. If you want to add anything to the head click on the Settings button and do it there.

Go ahead and work on passing the tests. Read each of the error messages as they tell you why the test failed.

Then, when all the tests pass work on styling it. Right now your page isn’t responsive. The timeline has each word on a separate line and on a smaller screen the user has to scroll way right in order to see it.

Repost when you you’ve cleaned it up.
And as an aside, one space in your link like I showed would have been sufficient.

Thank you Roma. I have passed 7 of the 10 now, working on the rest. I did try one space in my link and it didn’t let me post. I went a bit overboard though. lol

You should be able to post links soon but until then you can leave off the protocol and the codepen.io part (I.e. https://codepen.io)

Thank you!
I appreciate your feedback.

I’ve finished and passed all the tests. So happy I’ve completed it and passed. :grinning:
Just need to work on cleaning it up.