As a new developer I found the wording of this very confusing. Referring to the second argument as a truth test had me wondering if I’d missed some sort of important lesson but after talking over the problem with my mentor I realized it was simply a function being called a “truth test”. Perhaps the wording could be changed to reflect what the truth test is other than referring to it as simply a second argument.
Would you be willing to open an issue about this? you could suggest a new wording yourself, or even do the correction yourself.
Thank you for helping make FCC better. Bugs can be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.