Finding Package.json results in 404

Tell us what’s happening:
The Tests return “package.json should have a valid “author” key” even after I included the author key.
The file search fails while appending some “_api” ass part of the search string.


Your code so far
{
“author”: “Duho Wise”,
“name”: “fcc-learn-npm-package-json”,
“dependencies”: {
“express”: “^4.14.0”
},
“main”: “server.js”,
“scripts”: {
“start”: “node server.js”
},
“engines”: {
“node”: “8.11.2”
},
“repository”: {
“type”: “git”,
“url”: “https://idontknow/todo.git
}
}

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0.

Challenge: undefined

Link to the challenge:

@duhowise Can you please post a link to your Glitch project, so we can take a look at your code?

1 Like

This is the link to my glitch project: https://glitch.com/~pouncing-cactus
I am sharing the GitHub link as well because it has the same issue: https://github.com/duhowise/boilerplate-npm

Hello Sir, I Have added the link to the projects as requested. Please help as I cannot complete any of the challenges in this course due to that reason

Your Glitch project is passing the challenge for me. Remember that you have to submit the link to the page (https://pouncing-cactus.glitch.me) and not the link to the json file.

1 Like

Thanks. I just tried the glitch and it worked!
How do I get the github to work?
here is the link:https://github.com/duhowise/boilerplate-npm

I assume you have to upload it to some platform that lets you run node code. The “or clone this repository on GitHub” is just a way of getting the starting code (as far as I know).