Finished Mario database but not checked as completed in curriculum

I have finished the Mario Database but still no completed sign in curriculum section. I refreshed the curriculum section a few times. I did the mario course in one go without signing out.

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.82 Safari/537.36

Challenge: Build a Mario Database

Link to the challenge:

There’s some more trouble shooting steps here @Erik-NA7 - not sure if you saw them. You said you didn’t sign out, so your user token shouldn’t have been deleted, but here’s how to double check. It sounds like you tried these, so I’m not sure. Maybe try them one more time? Let us know if anything works.

The screen shot I took was the one that shown after clicking continue at the last section of the course. I tried to start the course again, this time the CodeRoad didn’t run automatically. I run the CodeRoad again and it shows the continue button for the last step immediately. So my progress was saved.
Once I clicked the ‘continue’ button of course it shows the same ‘Congratulations on completing…’ screen.

Anything else I should check?

That should have worked - after that, you went back to the freeCodeCamp curriculum page, gave it a refresh, and it still didn’t show the check mark? Did you complete the bash boilerplate project and get a check mark by that one?

Yep, went back to curriculum, gave it a refresh, still no check mark. I have completed the boilerplate project without any problem.

It really sounds like a user token issue. Did you try that link I shared on how to double check? I would try that if you haven’t. If you have, I really don’t know what else could be going on.

I didn’t sign out, are you suggesting I try signing out and sign in again to refresh the token?

No, I’m suggesting to follow those instructions that update your token in the VM.

…existing VM’s still have the old token until it shuts itself down. I’m not sure if that’s the issue, but here’s what you can try - open up a different project, any one - that will shut down your running celestial bodies Mario project. Then go open the celestial bodies Mario project back up, the container should now have your new token - and, if you finished the project, it should take you right to the last screen. Press that continue button to submit the project again. If this is the issue, it should now be saved and show up the next time you refresh your freeCodeCamp page.

1 Like

It works now. I misunderstood this step. Thank you!!

1 Like

I have the same issue - I have completed boilerplate bash but its not showing as complete in the curriculum.

I’ve tried following the recommended steps closing and going back in from the start this course button again and it shows the module as completed, but still nothing showing up in FCC.

Not sure what else to try??

Edit: -------------

OK… Fixed now… The issue seems to relate to CodeRoad not automatically starting (I was having to manually start it from the command pallet). After a couple of goes at logging back into the course, CodeRoad auto started correctly, and this time it looks like the token was passed successfully

1 Like