.flavor { text-align : left }

Tell us what’s happening:
I don’t seem to understand why I’m not passing.
My code has .flavor { text-align : left } and it’s working on the website preview on the right side as well. The flavor is moving to the left indeed but I still can’t seem to pass.

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>Cafe Menu</title>
    <link href="styles.css" rel="stylesheet"/>
  </head>
  <body>
    <div class="menu">
      <main>
        <h1>CAMPER CAFE</h1>
        <p>Est. 2020</p>
        <section>
          <h2>Coffee</h2>
          <article>
            <p class="flavor">French Vanilla</p>
            <p>3.00</p>
          </article>
          <article>
            <p>Caramel Macchiato</p>
            <p>3.75</p>
          </article>
          <article>
            <p>Pumpkin Spice</p>
            <p>3.50</p>
          </article>
          <article>
            <p>Hazelnut</p>
            <p>4.00</p>
          </article>
          <article>
            <p>Mocha</p>
            <p>4.50</p>
          </article>
        </section>
      </main>
    </div>
  </body>
</html>
/* file: styles.css */
body {
  background-image: url(https://cdn.freecodecamp.org/curriculum/css-cafe/beans.jpg);
}

h1, h2, p {
  text-align: center;
}

.menu {
  width: 80%;
  background-color: burlywood;
  margin-left: auto;

/* User Editable Region */

  margin-right: auto;

/* User Editable Region */

.flavor {
          text-align: left
        }

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/115.0.0.0 Safari/537.36 OPR/101.0.0.0

Challenge: Learn Basic CSS by Building a Cafe Menu - Step 33

Link to the challenge:

You are missing a closing brace } for your menu class styling

1 Like

Thanks for pointing that out. Any advise for the .flavor part? It’s still not working for me.

Nvm it worked. Thanks a lot man.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.