FreeCodeCamp Curriculum Page Tells Me To Sign In When I Have Already Signed In

On the front page of FreeCodeCamp, when I sign in, it tells me my progress and lets me access my account settings. However, when I go on the curriculum page it shows me a ‘Sign In’ yellow button on the top right and doesn’t show my curriculum progress. I can’t do the challenges if it won’t update on the curriculum page.

1 Like

I’m having the same problem, its been like this since last Thursday. Signing out and back in again manually doesn’t fix it either.

Same here. If I click the sign in button I get the front page with my name on it but then when I go to the curriculum it’s all blank. If I go back to the settings it shows all I’ve done so my progress is still available somewhere. Someone mentioned in another thread it may be a problem in Aus/ NZ only so for the record I’m in Australia.

Having the same issue. Have tried logging in and out with both GitHub and Email account. Cant access the curriculum page but have access to the home page.

If you’re in Australia or New Zealand the work around is to use a vpn. Curriculum Kicks me out. I used windscribe for chrome but most are using the work around with Opera

This issue looks to have been resolved!

This has been resolved, please see:

I have been having the same issue for over a week logging in here in the US.

Just started using freecodecamp for the first time the other day, but this started happening to me. My completed challenges is stuck at 10 no matter how many I do now, going to curriculum shows the sign in button, but clicking on it brings me back to the home page signed in. I think this is because the front page is on the www subdomain, while the curriculum and lessons are under the learn subdomain? I do have a few browser extensions that could be interfering, but I’ve tried disabling them and clearing cookies, local storage, etc with no luck.

I’m in USA california btw.

Oh, I have solved the issue for myself by googling a bit more. As suggested by this logging out and signing back in with email, rather than social media / github fixed it for me.