FreeCodeCamp has a problem making it almost impossible to finish Quality Assurance and Testing with Chai - Test if a Variable or Function is Defined

Tell us what’s happening:
Is something down periodically on the backend? Is something wrong with Replit? I started this yesterday and couldn’t finish lesson 1 at all. Got it to submit finally today but now it’s the same with 2. It just gives Flask or X next to all the items that should be a success symbol instead. I noticed I got 1 to work after commenting out all the other tests in case the line about “All tests must pass” means this is a trick question and we need to comment out all the unit test s the course hasn’t made us fix yet. Tried same trick for 2 but it’s still not submitting so I think I got lucky and found the short period when whatever is broken on FCC or Replit’s end was temporarily working. Why is there no indication when it’s down like this? What a waste of time…

Your code so far
test(‘#isDefined, #isUndefined’, function () {
assert.isDefined(null, ‘null is not undefined’);
assert.isUndefined(undefined, ‘undefined IS undefined’);
assert.isDefined(‘hello’, ‘A string is not undefined’);

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Quality Assurance and Testing with Chai - Test if a Variable or Function is Defined

Link to the challenge:

and wow it’s been 41 minutes and i’m still on this. it actally did say congratulations at one point but it didn’t give me credit that time. back to spamming…

the one success message was while i had all the unit tests that commented out except the ones that pass now so i’ve left it in the state, but idk if replit could have messed with any lines of code while i’m not looking

I’m having the same problem. After getting the tests to pass in Replit, whether they pass or not in FCC seems to be totally random. boilerplate-mochachai - Replit

I have same problem before to finish chai part in quality assurance lesson. Its not work in repl, you need to just clone github repo for chai session and run in your localhost. And then copy your localhost link to FCC page. For me, its worked.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.