Freecodecamp is heavy

Freecodecamp is heavy
0

#1

Tell us what’s happening:
I am trying to press run the test and it is not working,neither here or on the next challenge
after lots of refresh and reset it works , why it is so heavy on javascript?

Your code so far


var myStr = "I am a /"double quoted" string inside /"double quotes/".""; // Change this line


Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/javascript-algorithms-and-data-structures/basic-javascript/escaping-literal-quotes-in-strings


#2

Welll, your code has a typo. You use / instead of \. Maybe it doesn’t have to do with the challenge not being working, but you should fix it.


#3

Nothing is happening because you are not solving the problem, check the amount of " in your code, and also remember when you want to signal a quote instead of a string you need to use \


#4

actually I have solved this challenge ,the point is It’s not running …if u r wrong u would press run the test and it will tell u what’s wrong on the side window …
I have to refresh and close the window ,reset so it can work and it’s not recording my progress too since then


#5

Well the thing is with that answer that you posted nothing will happen because of an extra " you got there and the fowardslashes instead of backslashes, basically you just put a bunch of strings on a variable, with no commas or anything.
Edit: I’m a total noob btw, I just did that challenge yesterday and that’s what i believe is wrong. Let me know if you need me to be more specific.


#6
var myStr = "I am a \"double quoted" string inside \"double quotes\"."; // Change this line

I appreciate your reply …I’ve passed this challenge too
I guess the right answer is what I’ve typed above
it’s just not working when I press ctrl+enter as usual
I want to run the test but I’m stuck ;(


#7

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make easier to read.

Note: Backticks are not single quotes.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.


#8

The latest code you posted will not pass the tests, because you have not properly escaped the double quotes.


#9

Thanks alot …I always had that question in mind
my problem is not solved yet …I’m not sure if you understand it ,I’m just so frustrated that specific button " run the tests" is not working, I’ve searched the web and I can’t relate to any of the results (not sure if I’m using proper English too) can you please help!!!


#10

@manarsalah, whenever you have error in syntax, the “run the tests” button does not work.
Listen to all the points @SpaniardDev, @opachano and @randelldawson have mentioned.
Try to get your syntax right.


#11
Function reusableFunction(){
    console.log("Hi World");
}
reusableFunction();

I moved on and the same happens now on other exercise on Basic JavaScript
now what’s wrong with that
I put three dots before and after my code and still not showing as readable


#12

If you read what I posted, it says to use 3 backticks and not 3 dots.


#13

thanks again Mr.randelldawson
:smile:
I hope u r not bothered by me as u sound haha, I really appreciate your help .


#14

No worries. I assume you are wondering why your current code posted does not work?


#15

well yes please …
note:I just want to mention that I’m brand new to coding , I’ve passed some chapters on HTML and Css and I wouldn’t face that problem with ctrl+enter or run the tests command , I could be wrong but it run and show me what’s wrong on the side window by X symbols followed by statement …
I hope I’m not talking too much I just want to get a respond on that
(not sure if it is my bad English , or me being a girl , or being new to coding , but I’m not giving up :muscle:
)


#16

JavaScript is case-sensitive, so you must always make sure you are using the correct case when using variables names, function names, methods, and key words. In your case, Function is not a valid keyword in JavaScript. However, lowercase function is.


#17
function checkSign(num) {
return (num>0)? "positive" :(num<0)? "negative":(num=0) "zero" ;
}

checkSign(10);

now the page is not responding


#18

What challenge are you working on? It is best to start a new topic if you have questions about a specific topic. In fact, it is best that you click the Ask for Help button located on each challenge, so the code, the challenge url and your question is all in a single post.


#19

yes I got it …actually the topic headline is the main issue , I’ve been trying to ask by showing u examples of the challenges that are not responding.
I came to a conclusion that the Basic Javascript module is some how heavy or not responding unlike other modules…
As I have tried different browsers, operating systems , and PCs also different account …that module is not working smoothly like others
I just wanted to report that
Thanks everyone


#20

Not sure if you’ve solved this already but at first glance I see at least two corrections you need to make in your function.

  1. Your last check is not a check but an assignment; num = 0 is an assignment while num === 0 would be a check
  2. In that same area there seems to be a missing question mark; see syntax for ternary operator

Not sure, but you might be missing a closing bracket there somewhere as well.

Hope this helps.

P.S. By “heavy” I assume you mean stuck, as in frozen or not functioning? Try to fix the points I mentioned and retry.