Git - Test Runner Failed @ 1553

I started the SQL Object tutorial last evening and the power went out. I resumed it today and I’m getting an error “test runner failed”.

I’ve used git log, git status, etc to see if it looks like I’m on the correct step and it looks like it saved my progress at the prior test, but that test shows it’s passed.

So I did the prior step (commit the UNIQUE reference), then tried the current step again (git reset HEAD~) and it is giving me this error:

Test Runner Failed

I have tried restarting the tutorial and doing a soft-reset.

Is there a command I can use to restart the test or the watcher? I didn’t find this as an open issue in the forum.

Thanks. I was enjoying this one too!

if it helps at all, this is the output of my git log --oneline command, which doesn’t reflect the prior step when I restart the tutorial, like it’s one step behind. I’m also seeing folders I don’t normally see that expose the tutorial and the .freecodecamp hidden folder.

codeally@d64b5d1ab4a0:~/project/sql_reference$ git log --oneline
4e3d744 (HEAD -> feat/add-column-references) feat: add column reference
87db07c (main) feat: add delete row reference
a72acea feat: add update row reference
88989a2 feat: add insert row reference
d3609d2 fix: create table syntax
0ae0bd4 feat: add drop table reference
18f0344 feat: add create table reference
684afe7 feat: add drop database reference
a5de944 feat: add create database reference
a029be1 Initial commit
1 Like