"Global Scope and Functions" - Run Button not working

"Global Scope and Functions" - Run Button not working
0

#1

Hello everybody,

I have been stuck at “Global Scope and Functions”. It’s not about the solution or anything the like, but about the functionality of the page itself. It doesn’t matter what I type in the editor, none of the code runs in the lower part.

Whenever I press the “Run the Tests” Button, it also does not have any functionality at all. No error. Nothing.
All other challenges work perfectly and their respective buttons and editors function properly.

I already tried clearing the browsing data, logging in and out as well as using completely different browsers. Nothing helps.

Does somebody have an idea?


#2

Is it happening in chrome too.? I had a problem about 20min ago, like my links to tests were not working in firefox but worked in chrome and when i tried now, it works in firefox too, maybe wait for sometime


#3

Thanks for the answer Sujith!

I solved the problem.
Maybe it might be of interest for anybody. I noticed that the quotation marks were the following:

“ ”

I changed them to those:

" "

Very subtle difference, but completely broke the page for me. Now it’s working!


#4

Yeah, i have noticed it too a few times.
Whenever you have a syntax error like you do not put the curly brackets or semicolon properly or any other error in your code it happens.
Always better to check code in chrome console when that happens.


#5

If you’re using an Apple device, turn off “smart punctuation” in the settings to avoid getting those weird quotation marks.