"helmet" dependency should be in "package.json" error returns while submitting challenge

Tell us what’s happening:
I have included helmetJS dependency in package.json file and require this module in my JS file, Still, I am getting below error while submitting my challenge,

// running tests
“helmet” dependency should be in package.json
// tests completed

Can anyone please help how can I pass this challenge?
Thanks in advance!!!

Your code so far

  "name": "fcc-infosec-challenges",
  "version": "0.0.1",
  "description": "fcc backend boilerplate",
  "main": "server.js",
  "scripts": {
    "start": "node myApp.js"
  "dependencies": {
    "express": "^4.14.0",
    "helmet": "^3.21.2"
  "engines": {
    "node": "4.4.5"
  "keywords": [
  "license": "MIT"

Challenge: undefined

Link to the challenge:

Hi @ajayit28 I think you are submitting the github url that’s why you are getting the error. try completing the challenge on Glitch.

Hi @Abbas-000, Thanks for the reply
I have tried the same code on Glitch but I got the same result.

can you send me the glitch url of your project you that I can check better

This is working fine for me. paste this https://amethyst-sink.glitch.me into the challenge input.

1 Like

Thank a lot @Abbas, This is working for me now.
Now i understood that we have to pass the Live App link URL.

I’m having the same error, can you help me too, ps?
Linkt: https://dorian-fragrant-savory.glitch.me

@ajayit28 Yes, I click on Link to Glitch > Live App > copy
Link: https://dorian-fragrant-savory.glitch.me
Still not working for me.

New link: https://michelics-infosec.glitch.me
Still the same error =(