Helmet middleware should be mounted correctly

Tell us what’s happening:

Failed test:
helmet.ieNoOpen() middleware should be mounted correctly

Your code so far

app.use(helmet.ieNoOpen());

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0.

Challenge: Prevent IE from Opening Untrusted HTML with helmet.ieNoOpen()

Link to the challenge:

Ok, downgrading helmet to ~3.21.0 helped. Just annoying…

1 Like

Hello; I’ve had some tests pass and several errors(test fails =mounted incorrectly) with no difference between things that pass and those that fail.
I see above comment - how do we downgrade helmet?
I’ve tried just typing in suggested version of 3.21.0(but not working), because I didn’t see it in the available package list usually used to add a package.

Any idea how to downgrade helmet if that is the problem?
Or any other ideas - seems like lots of random problems with this middleware
Thanks
Paul

1 Like

In package.json change the version of helmet to ~3.21.0

(...)
	"dependencies": {
		"express": "^4.14.0",
    "helmet": "~3.21.0"
	},
(...)

That worked for me.

1 Like

Ha! So easy!
Thanks for that!