Help with glitch - Introduction to the Basic Node and Express Challenges

Hi,

I am having trouble in the “Introduction to the Basic Node and Express Challenges” and I believe it is due to the set up of the glitch project. I am probably making a really simple mistake, but I am nut sure what it is.

when I follow the link from the Introduction to the Basic Node and Express Challenges page (https://glitch.com/#!/import/github/freeCodeCamp/boilerplate-express/), there are always a few pages which show

If I run refresh from the console as it suggests all the files in the sidebar disappear as shown in this picture

I have also tried importing the github repository into glitch


but it does not work and the following message appears
image

I have managed to do the first few challenge in this section by using links to glitch project that other people has posted in this forum but I have got stuck on the “serve static assets” challenge and I am pretty sure it is due to having the glitch is set up wrong.

Thanks for your help

did you figure this out yet ?

Hi,

No, I haven’t worked it out yet. I have tried in other internet browsers to see if that was the issue, but this did not fix it.

I normally get the “This document is deleted outside of editor message” on the client.js, style.css, index.html and sometimes the server.js file.

For the server.js file I can just copy and past the code from github but when I try to do this for the other files, all the files disappear from the sidebar like in 2nd picture in my first post.

Thanks.

Your above linked boilerplate works fine for me , however I’ve also had the same issue before, I believe it is a glitch problem, but going to advanced options > open console and then typing refresh and enter ALWAYS fixes the problem for me. I’d completely delete the problem project from glitch , log out and back in, and try the above with a fresh boilerplate. Like I said the above link works fine with no problems for me, just tried it.

Hi,

I have worked it out. I had to log into glitch with my github account, previously I had just logged in with my email address. Now all the files seem to show up ok.

Thanks for you help.

2 Likes