Help with Step !4

I’ve always wondered what is wrong here.

The instruction was: Turn the image into a link by surrounding it with necessary element tags. Use https://freecatphotoapp.com as the anchor’s href attribute value

And here is what I have:

  <a href="https://freecatphotoapp.com"> 
   <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"</a>

At the end of the day, I still got an error message

Hint

“You should only add one opening anchor ( a ) tag. Please remove any extras”

Well one thing that sticks out is your img seems to be missing a closing bracket: >

…but that could just be a formatting issue, or it might not have been copy pasted right, and I don’t think that would cause this particular error.


Could you share your full code formatted? You can format it by copy/pasting it between two lines of three backticks:
```
your code here
```
It sounds like somewhere in your code you might have accidentaly used an extra <a> tag, or possibly written your closing tag as an opening tag.

<a>    Opening tag
</a>   Closing tag

You are missing the > in the image element

It did not still work out

<a href="https://freecatphotoapp.com">
   <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" >
   </a>

:heavy_multiplication_x: Sorry, your code does not pass. Try again.

Hint

Your anchor ( a ) element should have an opening tag. Opening tags have this syntax: <elementName> .

This code works for me.
There must be some problem with your browser.

  • Try disabling extensions.
  • You can also try it in an Incognito Window. Or in a different browser.

Thanks, I would try it out on another browser

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.