Heroku app showing old code?

Heroku app showing old code?
0

#1

I’ve finished my voting app and deployed it to heroku, but noticed a pretty serious bug so I fixed it, committed the changed files, updated them on github, and redeployed it to heroku. And even though I had tested it on the local server and found everything to be working, the same bug was showing on heroku, and I know it’s old code because I had also changed the styles. I tried everything, even destroying the app and creating a new one, but the old code kept showing. Has this ever happened to any one before? Does anyone know of a fix? Thanks in advance.


#2

If the bug was on the front end the first thing that comes to mind is the browser cache.


#3

Thanks for the reply! I think I got it to work. I cleared the browser cache but it still wasn’t working. But simple mistake, turns out I forgot to recommit the css and bundle files. Even then though, I’m noticing that destroying the app and creating a new one does actually work sometimes.


#4

:slight_smile:

git status is my most used git command.