How are you able to use FCC beta

How are you able to use FCC beta
0

#1

Hello fellow campers,

Please, who is currently undertaking the FCC beta curriculum?

I am unable to open any of the tracks (frontend, backend etc.). The page just returns “Something went wrong, please try again later”

Any tips as to how one can overcome this error.

Any help will be appreciated.

Thank you.


#2

Hi,

AFAIK, beta is not fully functional yet and you can’t sign up. You can do individual challenges, but you can’t save your progress. You can off course save your solutions somewhere else and submit them when beta goes into release.


#3

Hi @kevinSmith,

I understand that the curriculum is in beta but I am unable to open any of the challenges to start with.

The page only returns a dialog box with the message "Something went wrong, please try again later”.

Are you able to view the challenges, and also what browser do you use?

Thank you


#5

There’s a bug report for this already: https://github.com/freeCodeCamp/freeCodeCamp/issues/16468

Did you previously log in and do some of the challenges? Have you tried accessing the beta site from a different browser? From a private browsing window? (without logging in)

The beta site won’t store your progress anyway, so you should save your solutions locally if you’re able to get back in, to re-enter when the site goes live.


#6

Thank you @r1chard5mith.

I have been able to sing-up and login afterwards. I have safari and chrome installed, which I used while trying to access the challenges, but got the same error message.

Are you able to login and access the beta curriculum.


#7

I can access it without logging in and get to any of the challenges, but it seems like I can pretty reliably trigger ‘something went wrong’ but I haven’t probed it systematically. When I had the local install running recently, I wasn’t able to trigger the same behaviour. I don’t know much about the system in general, so I’ve no idea if this is likely to be a simple or difficult fix.