How to fix it ? I m running it on a WSL

WSL install will try to automatically change the Ubuntu locale to match the locale of your Windows install!

Can you please explain what you’re trying to do when you post another one of this series of screenshots. Again, you are not going to get useful replies, as demonstrated, because you are not explaining what you are doing. You are trying to run an extremely specific thing on a specific OS, and afaics you haven’t done anything but post screenshots of your errors. I don’t mean to have a go, it’s just very difficult to provide help. For example, have you followed all of the instructions here?:

And it is also much easier to read text than it is to read screenshots: can you please copy and paste the errors rather than screenshots.

I m trying to run web server of my task cluster repo. Hope you get me .

Sorry .Did not get you .

Right, that doesn’t explain anything. You need to understand that you have never explained what you’re doing: “I’m running a web server of my task cluster repo” is meaningless. You almost might as well be saying “I have a thing I’m trying to run on my computer and it’s broken” without telling anyone what the thing is. We can’t read your mind!

I only know what you’re trying to do because I figured the path in you screenshot referred to some obscure repo you had cloned from GitHub. It was, and you’re running something from deep within a subdirectory in that repo.

You keep posting the same error (and although there are minor differences, it’s always the same thing). As far as I can see, I’m the only person who has dug through the docs and issues, because literally none of the other answers you’ve had in various threads has actually tried to address the specific problem:

  • you need to set a specific env var on a Windows machine, and the npm script that starts the web server module has been written for Unix machines, setting the env var on the fly, which Windows cannot do.

That’s not their fault, it’s because you’ve never explained what you’re actually trying to run, and what you’ve already tried and what you already have set up. I can’t even give you specific advice, because you have never said what instructions you have carried out from the repo README for setting up the server.

Have you modified the npm script in the package.json in the root of the server folder to either

  1. not set the variable on the fly in the start script (then manually set the variable on your system)
  2. install cross-env in that folder via yarn, then include cross-env in the start script as I suggested in one of your other threads?