How-to-npm help, npm outdated returning 404

I’m trying to do the outdated lesson on the how-to-npm module. when I run the npm outdated command I get a 404 that says express is not in registry? here is the full error message -

npm ERR! Linux 4.2.0-c9
npm ERR! argv “/home/ubuntu/.nvm/versions/node/v4.6.1/bin/node” “/home/ubuntu/.nvm/versions/node/v4.6.1/bin/npm” "outdated"
npm ERR! node v4.6.1
npm ERR! npm v4.0.2
npm ERR! code E404

npm ERR! 404 missing : express
npm ERR! 404
npm ERR! 404 ‘express’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ubuntu/workspace/npm-debug.log

I also accidentally deleted the async module, and when I tried to re-install it I get the same type of error. What’s going on here?


I just had the same problem with ‘npm outdated’ giving a similar error: ‘async’ is not in the npm registry.

While I don’t have a solution for this, if you just want to get ahead with the tutotial, you could try ‘how-to-npm verify PKG’ with PKG being any of the dependencies in your package.json. For me it worked and since the aim of this step in the tutorial is only to identify the outdated package, I can live with “hacking” through it :wink:
I hope it helps.

1 Like

That worked! thanks!

Hate to say it but that’s not working for me. I have three dependencies listed in package.json:, async, and express. I tried all three but the challenge says it isn’t any of them and says to “try again”. Is there another place I should be looking for dependencies?

Hi Joel,

I just tried ‘how-to-npm verify @linclark/pkg’ and it worked for me. Let me know if that works.


It does! Thank you for responding.

Awesome, you’re welcome!

Am trying to do NPM Test but I have been getting this error for a week now… Please help

nodejstutorials@1.0.1 test C:\Users\Thozamile\dev
node test.js

"name": “nodejstutorials”,
SyntaxError: Unexpected token :
at createScript (vm.js:56:10)
at Object.runInThisContext (vm.js:97:10)
at Module._compile (module.js:542:28)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.runMain (module.js:604:10)
at run (bootstrap_node.js:389:7)
at startup (bootstrap_node.js:149:9)
npm ERR! Test failed. See above for more details.

Uh oh! The test failed!
Try creating a test that actually works.