How to turn off auto closing of brackets and quotes

How to turn off auto closing of brackets and quotes
0.0 0

#1

Hi!

I have been trying to disable the auto closing of brackets and quotes when doing the JavaScript challenges, but can’t seem to find how. Any suggestions?


#2

Not sure if there is any direct way to do that.

As I checked, when you enter a double quote, or open block, it(editor) puts the closing pair next to it as you mentioned. But if you attempt to close the pair, it will be ignored. So no any syntax issue will be there.

I would do open and close char myself when coding, and sometimes I never notice if the IDE/editor places the close pair once I type the opening one, but again as I type the closing pair, it doesn’t mean it’s one open and two closing. In fact my closing is ignored becasue it’s already there.(if it’s not same for you, you may try it with another browser)

Not just FCC, other IDE and editors out there come with same behavior, but some of them may let you disable this feature.

I think you should not be worry about it, and try to get along with it.

Keep goin on great work, happy coding.