How to use glitch with FCC?

In your glitch project, Click the show Dropdown

and choose open in a new window option
when the browser loads the html page of your project,
copy and paste this url in the Solution textbox.


Sorry, I fixed the issue. For those that can’t get it working:
Clone the fcc github from the link provided.
Create a new project on Glitch and select the option to clone from repository.
Then copy the link to the fcc GitHub.
Next Drag and drop the files from your cloned copy into glitch.(you can’t drag folders, so open the views folder on your cloned copy and drag and drop the index.html file.)
Next go to server.js file on glitch that you added earlier and change the file path of index.html by removing the views directory.
It should be:

this worked for me. thanks! I actually took it one step lazier and just downloaded the index.html file from FCC github, uploaded that to Glitch, and then changed the file path in server.js from ‘/views/index.html’ to ‘/index.html’

1 Like

the JSON needs node and express updated before it can run properly.

	"name": "fcc-learn-npm-package-json",
	"dependencies": {
		"express": "^4.16.4"
	"main": "server.js",
	"scripts": {
		"start": "node server.js"
	"engines": {
		"node": "10.16.0"
	"repository": {
		"type": "git",
		"url": "https://idontknow/todo.git"
  "author": "Todd" 
1 Like

I having trouble understanding this bullet point:

Start this project on Glitch using [this link] or clone [this repository] on GitHub! If you use Glitch, remember to save the link to your project somewhere safe!

Particularly the -remember to save the link to your project somewhere safe- part confuses me. What could happen if you don’t save the link to your project somewhere safe? And why save the link to the project somewhere safe? I paste the live app url to the solution bar and my tests passes fine. Is this link that I’m using to pass my tests what it is talking about?

All it’s saying is to remember the URL to your project.

Worked like a charm!

Thank you so so much @paviravirp.
That was the best explanation in this thread!:innocent:

This is the answer. Thanks

That was brilliant. Thank you

Tried all things mentioned above, it does connect to the project, but doesn’t result in success… :face_with_symbols_over_mouth: :clown_face: :skull_and_crossbones:

Anyone else have the same experience?

Hello. When I try this, I get the “this site can’t be reached” error. There is a way to fix this? Or is just glitch bugged?

to get a link to submit you can use the Share button, copy the link for the Live App and submit that one

Hi. Thanks for your reply! I’ve also tried in this way but the generated link doesn’t work : (this is the result just after cloning the boilerplate project…)

if submitting the link you fail the tests there are two possiblities: glitch is not working, or you need to work on it some more

I think is the first option…I’m pretty sure to had correctly changed the “author” property in the json :sweat_smile: Thank you anyway.

EDIT: I’ve found the problem: changind my DNS to enabled my glitch project to be visible from the freeCodeCamp test.