HTML Responsive design(collapse menu) and Password field not blank

can anyone tell me why these css don’t make my screen responsive for collapsing when my screen is diminished, AND, why my password field is autocompleted? I tryed lots of things, including autocomplete=“off” and it doesn’t work, here’s the code for both of them, check it out.

<title>SkyApp | Welcome</title>
<!-- Bootstrap core CSS -->
<link href="ficheiros_css/bootstrap.css" rel="stylesheet">

<!-- Custom styles for this template -->
<link href="ficheiros_css/font-awesome.min.css" rel="stylesheet">
<header class="header-main">
	<div class="navbar navbar-inverse navbar-fixed-top" role="navigation">
	  <div class="container">
		<div class="navbar-header">
		  <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-collapse">
			<span class="sr-only">Toggle navigation</span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
			<span class="icon-bar"></span>
		  </button>
		  <a class="navbar-brand" href="#">SKYAPP</a>
		</div>
		<div class="collapse navbar-collapse">
		  <ul class="nav navbar-nav">
			<li class="active"><a href="index.html">Home</a></li>
			<li><a href="about.html">About</a></li>
			<li><a href="services.html">Services</a></li>
			<li><a href="blog.html">Blog</a></li>
			<li><a href="contact.html">Contact</a></li>
		  </ul>
		  <ul class="nav navbar-nav navbar-sub pull-right">
			<li><a href="#">Register</a></li>
			<li><a href="#">Login</a></li>
		  </ul>
		</div><!--/.nav-collapse -->
	  </div>
	</div>
</header>

PHP SQL

//ENTRADA
echo ’

	<h3>Entrar</h3><hr><br>
	Para entrar no Micro Fórum, necessita introduzir o seu nome de utilizador e passe.<br>
	Se não tem conta de utilizador, pode criar uma <a href="signup.php">nova conta de utilizador</a>.<br><br>
	
	Nome de utilizador:<br><input type="text" size="20" name="nome_utilizador"><br><br>
	Passe:<br><input type="password" size="20" name="text_password"><br><br>
	<input type="submit" name="btn_submit" value="Entrar">
	</form>';

Before I can assist you, I would like you to answer some questions.

  1. Have you downloaded bootstrap CSS, JS & JQuery on your computer?
    It looks like you are linking bootstrap locally. If that is the case, you need it to be installed. If it is not the case, you will need to change the links.
  2. Are you using a script to populate your form, such as PHP or JavaScript?
  3. What is being prepopulated in your password field?
  4. Do you have a codepen account? If not you should create an account and create a pen with full code, The pen will make it easier for others to see your code and what happens when it runs.

Yes I have downloaded those on my computer, and they are on the right locations.
No, I am not using a script for PHP, but I am using bootstrap.js and jquery.
My password from the root of phpmyadmin.
Yes I have codepen account.

I will a copy of the code into there and see what happens.

I will look forward to seeing your codepen.
Have you tried putting the bootstrap js and jquery links in the head section of your html document? I had an issue where jquery link wouldn’t work locally unless I included in the head section. This may resolve the responsiveness issue.
It seems odd that it would populate the password field with your phpmyadmin
password. What server are you using? xampp, wampp ?
Just curious have you tried changing your password to be empty or blank?
in phpmyadmin under users tab change password to no.

I am using xampp. I don’t know why it populates it with phpmyadmin pass. I didn’t want to put password empty or blank for security reasons.

And yes, I linked js on the bottom, so I don’t get it if its file location, file mispelling, file linking, i checked these issues, though I must be wrong on something pretty basic, I just didn’t see it. Coincidentally, the dropdown menu on my first problem of front-end is happening again, but now in wordpress. I can’t make the dropdown menu to work on wordpress, much like this problem I’m having now. Any thoughts?

Really would be much easier to help you if you would create pen on code pen. I ran your code for the nav and the form on my machine with xampp and had no issues. One thing to consider is perhaps browser cache prepopulating the form field. Try clearing browser cache and see if the field is still pre populated. Other than that, I am wondering if there is some .ini setting in xampp that is creating the password issue. As far as wordpress, can’t help you there. I have zero experience with wordpress.

I tryed the responsive menu several times, I don’t really know what’s wrong because everything seems to be in place. I’m sure it must be something pretty basic, but no clue to what.

How are you including the bootstrap js & jquery in your document?
Like this ?
<script src="jquery-3.2.1.slim.min.js"></script>

<script src="js/bootstrap.min.js"></script>

<!-- Placed at the end of the document so the pages load faster -->
<script src="ficheiros_js/jquery.js"></script>
<script src="ficheiros_js/bootstrap.js"></script>

Like this:

<!-- Placed at the end of the document so the pages load faster -->
<script src="ficheiros_js/jquery.js"></script>
<script src="ficheiros_js/bootstrap.js"></script>

I still don’t see whats wrong.

Your post did not show the code. Please highlight code and then click</> symbol at the top of the post editor.

 <!-- Bootstrap core JavaScript
================================================== -->
<!-- Placed at the end of the document so the pages load faster -->
<script src="ficheiros_js/jquery.js"></script>
<script src="ficheiros_js/bootstrap.js"></script>``

Does your menu responds in dropdown mode when u shrink window? Because mine doesn’t.

Yes it does.
What browser are you using?
Have you tried annother browser?
When you downloaded the jquery and the font awesome did you rename the files?
I believe the original downloads would include version numbers.
Your html, bootstrap, jquery, & fontawesome are all in the htdocs folder?

Firefox, but I have tryed others, its not the browser for sure. All browsers can support this simple functionality. Yes all files in htdocs. I can allways send you files, just like they are.

Again! It would be much easier to help you if you would create pen on codepen. If you are unwilling or unable to do a codepen, then I am giving up on trying to assist you.

Have you checked my pen? It doesn’t work for me in codepen as well, I tryed it already.

Hey man, thanks for your dedication, I encountered the problem, it was the name of the file, it was actually .js.js, but only the name appeared it had no problem. Thanks anyway man, twas worth the effort though, I know it was something basic.