I am unable to clone node.js projects from github

Tell us what’s happening:
I am at Information Security with Helmet.js project right now.
Before I always used either repl or glitch to submit my solutions and these worked like a charm everytime.
But now when I decided to be independent. Now I write my code in vscode.
I cannot figure out how to submit my solution through github repository.

Basically I want a way to submit my code through cloning a repository in github.
The link to the challenge is - https://www.freecodecamp.org/learn/information-security/information-security-with-helmetjs/install-and-require-helmet

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.102 Safari/537.36.

Challenge: Install and Require Helmet

Link to the challenge:

Hello there,

In order for the tests to run, the code has to be hosted on a server, visible as a live app. Submitting a link to text documents (gits) will not work.

GitHub offers GitHub Pages, which is a live preview of static files (frontend only). So, this only works for the frontend projects.

Some alternatives for the backend projects:

  • Heroku (host a free fullstack app, and build from GitHub. Very easy to use)
  • CodeSandbox
  • Repl.it
  • Glitch

Those are the top options campers use for the fCC curriculum. I have used all of them, and suggest you find one you are happy with. All of them allow you to clone a GitHub repo, to serve the files.

Hope this clarifies

1 Like

Thank you very much for replying. I have tried both Glitch and repl.it. I also made sure to copy the link of my live app.
I installed and required exact version of helmet.js and required it in myApp.js file too.
I still can’t figure out why it refuses to pass the tests.

Would you mind posting a link to your app?

1 Like

Sure. Thanks. https://repl.it/repls/DisgustingAffectionateCharacterset#myApp.js

I assume you changed this for local testing:

"scripts": {
		"start": "node myApp.js"
	},
1 Like

Yes. Can you try submitting a solution yourself and check if it is working or not. Because I am pretty convinced that there must be an error in the tests by now.