I can't pass the first test of backend

Tell us what’s happening:
i followed the “get a hint” guide, and i even copied the same package.json that was showed there (just to be sure that i don’t have a typo), but nothing works.
i tried also to delete everything in the package.json and wrote just

"author": "foo"
i tried also writing a new package.json file in the "public" folder, with just the author key, but it didn't work

**Your code so far**
        	"name": "fcc-learn-npm-package-json",
  "author": "oussama",
	"dependencies": {
		"express": "^4.14.0"
	"main": "server.js",
	"scripts": {
		"start": "node server.js"
	"engines": {
		"node": "8.11.2"
	"repository": {
		"type": "git",
		"url": "https://idontknow/todo.git"

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36.

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

Hello there,

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

Please use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks are not single quotes.


Here is the endpoint the tests use: /_api/package.json

You can use that to debug what is happening. Otherwise, I suggest you share a link to your project.

sorry, but can you provide the full link to me ( i didn’t know after what i put this)

I suggest you share a link to your project.

this is the link for the live app

this is for the invitation to edit if you need it

The idea is that this: /_api/package.json is an endpoint of your app. You place it at the end of your project link, and should see a text response.

It appears you are editing the README.md file…

Also, either you have edited files you should not have, or, you have the incorrect boilerplate code.

I recommend you go back to this page: https://www.freecodecamp.org/learn/apis-and-microservices/managing-packages-with-npm/

And click on the link to fork the project again.

Hope this helps

wow, i didn’t saw the link that pointed to glitch!
thank you!!!