I need help with this lesson of backend dev

Tell us what’s happening:
In the lesson number 12, i need to remove a people who have the name in the const, i did it but it don’t pass the test, i go to hint, and the people code looks very similar than the mine.

const removeManyPeople = (done) => {
  const nameToRemove = "Mary";
  Person.deleteMany({name: nameToRemove}, (err, data)=>{
    if(err){
      console.log(err)
    }
    done(null, data)
  })
};

What’s wrong with it please, i’m stucked here about two hours and no solutions .
Your project link(s)

solution: boilerplate-mongomongoose-1 - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.63 Safari/537.36 Edg/102.0.1245.39

Challenge: Delete Many Documents with model.remove()

Link to the challenge:

Install the version of mongoose that you are asked to in the initial challenge.

it doesn’t work, replit install automaticaly the latest version ,
my package.json =>

    },
    "dependencies": {
        "body-parser": "^1.15.2",
        "dotenv": "^8.2.0",
        "express": "^4.12.4",
        "mongodb": "3.6.0",
        "mongoose": "5.4.0"
    },

but in replit packages says “mongoose: 6.x.x”

Open the Shell tab and run:

npm rm mongoose
npm i -E mongoose@5.4.0

But you should be able to never use the packages tab and just do everything in the package.json file. However, it is possible that after you use the Replit packages tab it might result in some inconsistencies. But if you just remove the package first and then stick to only using the package.json file to add the packages it should work.