Install and Set Up Mongoose challenge not working?

Hey there,

My project is working in glitch and the tests don’t pass.

I’m not sure which link I am supposed to submit so I tried both.


// running tests
Unexpected token < in JSON at position 0
mongoose is not connected
Unexpected token < in JSON at position 0
// tests completed


// running tests
// tests completed

Either link complete tests at all.
Does someone know what am I missing?

I don’t think it should work with the FULL PAGE link as it is a setup root for express that it is getting but I’ve seen some people saying that is the link we are supposed to submit. Can someone clarify please?

If I try to comment the express code I get timeout results in FCC tests.

Thank you in advance…

I just found that if you go to the FCC challenge webpage, look at the network tab in Chrome Dev Tools, clean the network log, try submitting!/mongo-atlas-mongoose and, if you see the same as I do, you should see 3 network calls that got to /edit and their preview is To use Glitch, please enable JavaScript

I have JS enabled by default on my browser and it happens in both Chrome 76.0.3809.87 and Firefox 68.0.1.

Someone knows if there is something with this challenge?

I’m going crazy with issues open here and on glitch forum to try to tackle this but I’m losing my hopes that there is something I am not understanding that I am supposed to do. I’m thinking this may be an issue with the exercise tests code…

I didn’t check, but did you use the correct starter project? Make sure you are logged in to glitch before clicking the link.

Also, yes it is the full page link you should use for the submit.

Thank you so much @lasjorg I was going crazy without knowing what else to try… I have now completed the challenge.

I think that starter project link should be announced in the challenge!

That would have saved me quite a lot of time and hassle because my code solved all announced challenges but not with the right boilerplate and therefore the tests don’t pass…

How do I go about asking for improvement on this announced challenge? Create an issue on GitHub, right?

Thank you again for the help! :wink:

It is. You can find it on the starting challenge page.

Start this project on Glitch using this link or clone this repository on GitHub! If you use Glitch, remember to save the link to your project somewhere safe!

I will say you are far from the first to have this problem so I think it is safe to say that the link might need to be more prominent.

Yes, you can open an issue on the fCC Github if you want.

1 Like

What? Am I going blind?
The link really is there, but have to re-read most of the page with my mouse going over the text as I read to find the link :grimacing:

Found a related issue on GitHub although it is regarding the link being broken some months ago. I will leave a comment there. Thank you!