Install Require helmet

Tell us what’s happening:
Hello Everybody,
Even if the code seems written properly, it keeps me asking for helmet
Project live app link is
warm-valley-methane glitch me

Thanks for any help
Your code so far
package.json edited lines
“dependencies”: {
“express”: “^4.14.0”,
“helmet”: “^3.21.3”
},
myApp.js edited lines
var express = require(“express”); // Do Not Edit
var app = express(); // Do Not Edit
const helmet = require(“helmet”);

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0.

Challenge: undefined

Maybe because, it is because you are trying to use a package that isnt found?
Not sure though

No, I typed exactly what is written in the solution. But it seems I’m not the only one to have the same problem.

It is passing for me. Make sure you give the URL with https.

https://warm-valley-methane.glitch.me

Hello, it’s the same but it doesn’t work for me. Could you please tell me what browser are you using and which version of it?
Thanks

It passes in both Chrome and Firefox (latest versions). But it does actually fail some times.

Try running the test with the dev tools open (F12). Go to the Network tab and check the “Disable Cache” checkbox. Now run the test again (dev tools still open). You may also want to clear the cache and cookies for good measure.

If the test still fails, go to the Console tab and look for any errors.

Hello lasjorg,
thank you for your help otherwise I was unable to identify the problem. The problem is the http request to package.json that doesn’t work. Is there anothere development platform I can try to solve the problem or a workaroud to solve it? Thank you for your help, I attached a picture of the console

Can you try the submit in Chrome just to test?

Thanks, but I treid also on chrome and it does the same problem

the error is in the reading of package.json, it states ERR_NAME_NOT_RESOLVED Thanks again for your support

ERR_NAME_NOT_RESOLVED is often DNS or some kind of network issue. Here is a list of things possibly related to the error message.

Can you open the file in the browser?
https://warm-valley-methane.glitch.me/_api/package.json

It’s hard to say what might be causing it. It might be DNS, firewall/security block. We know it’s unlikely to be the browser (two different browsers and the cache disabled) so it seems more likely to be something external. Maybe you can try the submit on a different system and/or network?

Also, it might sound silly but can you try just submitting it a bunch of times in a row and see if it works, like 10 times or so just to see if it randomly works.

Thanks anyway, but I tried from 3 different computers, from home network and office network, linux and windows with all sorts of browsers, I tried with both glitch and github, but it doesn’t work. There should be some problem in the procedure, but for now I decided to put it in hold since other courses are working like html one and then I will proceed to javascript. Then I’ll see later if it will start working. Thank you so much for your help anyway. Kind regards