Installing React via cmd

Installing React via cmd
0

#1

I have been trying to install react but am getting this message. What could be wrong?
Thanks.

reactError


#2

Looks like you don’t have sudo installed. You can confirm with which sudo - it should tell you sudo not found.

Which operating system are you on?


#3

Don’t use sudo (you really shouldn’t need it anyway even if you could use it). You don’t have that program in the Windows environment (and it doesn’t make sense on your OS)

Sudo is about permissions on Unix-based-systems (you shouldn’t ever need to sudo with npm installs - or any programming lang manager - on Unix-based systems anyway). On the linux subsystem it’s slightly different within the area of the HD containing the subsystem’s actual filesystem, but even then you can’t faff on with permissions outside of it (in actual Windows)


#4

I am on Windows 7. If that is the issue how do I install sudo. Thanks


#5

Ok. I am very new to all these commands. I saw an instruction somewhere online with that installation command. I do not really know the use of sudo in the command.


#6

Does it install if you type that command without sudo at the start, and if not, what’s the error message?


#7

Yes I tried it without sudo and it worked fine


#8

Right now I am running “create-react-app name” but its not working


#9

It have finally worked. Maybe I was having internet connection issues.