Is it possible to undo "tutorial reset"?

Recently I ran into an issue with passing one task in the Building Bike Rentals DB as shown in the images below (I was halfway through the course)

The task:

I think my code is correct (b/c I checked it many times); perhaps something was wrong with the CodeRoad.

So this is what I attempted to fix it

  • First I tried to reset progress by killing the terminal and pressing the “reset” button many times, but it doesn’t seem to work
  • So I thought maybe “Reset Tutorial” may solve the problem, but it didn’t. Instead it reset everything back to square one!

My question is if there’s a way to restore my CodeRoad progress? Or will I have to do it all again (even though all my files & databases are still intact)?

My code:

Once you reset a particular exercise, the progress should remain intact. Only the current step is reset.
Can you try to access the exercise once more and confirm if you are still facing this issue?

Phew, you’re right, I think it is ok now.

Though accidentally reset the whole tutorial (which set me back to the first task), I was able to recover my previous progress by pressing “ctrl enter” many many times…


1 Like

I really think there is a bug with CodeRoad test for task 1210 (the first image in my post).

Even though, I have tried to reset progress/tutorial many times, the problem is still not resolved and I can’t move on to the next task.

I need some help with that

Try deleting that second comment, # send to main menu @michaelng-creative - I think the test may expect that not to be there.

Edit: Also, do you remember what you did to reset the tutorial to the beginning? There is a button for that, but I don’t think it was functional the last I checked. You shouldn’t be able to skip through the steps by hitting ctrl+enter - something may have gotten messed up for you.

Yeah, I think it was kinda messy haha. I had to delete CodeAlly’s container and restart again.

Anyway, that helps a lot, thanks!

1 Like