Issue Tracker one test doesn't pass no matter what

Tell us what’s happening:
I’m doing the Issue Tracker quality assurance project and It seems there is an issue with fCC’s test. One of the tests done on the fCC website when clicking I've completed this challenge seems to not happen as intended, making the checkbox to never tick for:

When the PUT request sent to /api/issues/{projectname} does not include update fields, the return value is { error: 'no update field(s) sent', '_id': _id }. On any other error, the return value is { error: 'could not update', '_id': _id }.

I created a verbose mode on my test to see what is being tested and it isn’t testing for:

const badIdDelete = await $.ajax({
      url: url,
      type: 'DELETE',
      data: { _id: '5f665eb46e296f6b9b6a504d', issue_text: 'New Issue Text' }
    assert.deepEqual(badIdDelete, {
      error: 'could not delete',
      _id: '5f665eb46e296f6b9b6a504d'

as intended. (see I tried probing around to see how the fCC test work, but I can’t seem to figure out where the testing code is located…

Your code so far
Here’s my project link:

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 11_1_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36.

Challenge: Issue Tracker

Link to the challenge:

SOLVED: There was an error in my code, as usual, user error.