When I read and did this challenge, I guarantee I did not read past the name of the method. In code this test says:
def check_funds(self, amount):
if self.get_balance() >= amount:
If the balance is greater than or equal to the amount I want to spend, return true, else false.
I believe the user story needs a ‘more’ in place of a ‘less.’ You have the correct reading of the user story, but the author had a different intention.
I don’t know if it’s been done yet, but someone needs to follow the advice at the end of the aforementioned thread and report the issue.