Issues with Local Relational DB Course on Fedora Linux

TL;DR: The RDB course seems to assume it’s running on Ubuntu, even when it’s running on my Fedora machine. The setup scripts even force Fedora to add and update from Ubuntu repositories, which is disruptive for my machine.

So after I ran into the CodeAlly error that many others are talking about, I decided to try the Relational DB course locally on my Fedora machine according to the guide. Installing Docker was fine, I already had VS Code and Git, and everything went well until I ran Dev Containers: Rebuild and Reopen in Container.

Here’s where I don’t understand fully what happened. When I first ran that command a few days ago, it always errored out. It was trying to update from Ubuntu repositories, even using apt instead of Fedora’s dnf. In retrospect, the really strange thing was that it was erroring out. Maybe it was a network issue – I had been having issues with getting Fedora to recognize the computer’s Broadcom wifi card (I had my phone plugged into my Fedora machine for internet access, but maybe that was messing with apt somehow?). I dunno.

Sometime between then and now, the wifi problem got solved.

Just a few minutes ago, I ran that same command again, Dev Containers: Rebuild and Reopen in Container. This time, all the apt commands did run successfully (hence why I think it might’ve been a network issue), but the script added a ton of other repositories on my machine. Now, even when I run sudo dnf upgrade in my own terminal, my machine still thinks it has to get updates from Ubuntu repos. In particular, if I just run sudo dnf upgrade, it tells me I have to install the latest Google Chrome (which as a privacy-crazy guy is, uh… unwelcome). I’ll have to go in there and figure out what repos I need to delete and what ones I need to keep. Ugh.

EDIT: It looks like it really only added a repo called google-chrome. I think, anyway. Still strange.

Are there any plans to address this issue already? If not, would it be better to (1) remove all the update-y parts of the script and just (2) put an asterisk in the guide that if you’re setting up the RDB course on Linux you should first manually run whatever update command is offered by your distro?

Thoughts?

Hello there,

I might be misunderstanding what you are referring to, but Dev Containers support many Linux distros (Fedora included), and should not be doing anything more than running some Docker commands.

So, the only time Ubuntu specific commands should run is in the container itself, because that is an Ubuntu image.

At the end of the day, there is nothing unique about the container image or repository. So, it is more likely an issue with tooling on your machine. Try downgrading a few things. Specifically, the dev containers extension.

We do not have any scripts other than the Dockerfile. The Dockerfile is dead-simple - bases the official ubuntu image, and performs common tooling setup inside the container. So, there is nothing to remove.

Did you try to run any of the commands locally (instead of within the container), because that is the only way I can think of your machine reaching this point:

Hope this helps

1 Like

So, the only time Ubuntu specific commands should run is in the container itself, because that is an Ubuntu image.

Wow, I didn’t know that! That makes a lot more sense though. :upside_down_face:

Did you try to run any of the commands locally (instead of within the container)

Yes, that’s what I was referring to there. I opened up a separate terminal app to run sudo dnf upgrade. I also ran a command to list all my repos, which included that newly-added google-chrome repo, which I did not add myself and which I don’t believe was added before I ran the Docker script. But I admit it probably has to be some issue with my machine. :expressionless:

Regardless of what happened, thank you so much for clarifying @Sky020.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.