Its asking me to put a type attribute in the button element and I don't understand

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**
<html>
<body>
  <h1>CatPhotoApp</h1>
  <main>
    <section>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
      <a href="https://freecatphotoapp.com"><img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."></a>
    </section>
    <section>
      <h2>Cat Lists</h2>
      <h3>Things cats love:</h3>
      <ul>
        <li>cat nip</li>
        <li>laser pointers</li>
        <li>lasagna</li>
      </ul>
      <figure>
        <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/lasagna.jpg" alt="A slice of lasagna on a plate.">
        <figcaption>Cats <em>love</em> lasagna.</figcaption>  
      </figure>
      <h3>Top 3 things cats hate:</h3>
      <ol>
        <li>flea treatment</li>
        <li>thunder</li>
        <li>other cats</li>
      </ol>
      <figure>
        <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/cats.jpg" alt="Five cats looking around a field.">
        <figcaption>Cats <strong>hate</strong> other cats.</figcaption>  
      </figure>
    </section>
    <section>
      <h2>Cat Form</h2>
      <form action="https://freecatphotoapp.com/submit-cat-photo">
        <input type="text" name="catphotourl" placeholder="cat photo URL" required>
        <button>Submit </button>
     
      </form>
    </section>
  </main>
</body>
</html>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.5 Safari/605.1.15

Challenge: Step 42

Link to the challenge:

<button type = "challenge_value">button text</button>

Your button element should have a type attribute with the value submit . You have either omitted the value or have a typo. Remember that attribute values should be surrounded with quotation marks.

is says that its wrong and gave me this hint
this is step 42

Do you have a type attribute with the value of submit?

how to put it? I tried
submit
and it didn’t work

What is your updated code?

<input type="text" name="catphotourl" placeholder="cat photo URL" required>
      <button> submit </button>

You deleted the type attribute. The type attribute is required

te pide agregar un boton de radio dentro de una etiqueta label que tenga como texto de contenido indoor.
para eso tienes que poner:
label> input type=“radio”>indoor</label
todo esto dentro de la etiqueta que ya tienes colocada.

Quite algunos “<” y “>” para que puedas ver el codigo

oki where to put it??
I tried inside the before the submit it didn’t work
like how the code is supposed to like like???

You add it to the opening tag, like you’ve done with other attributes

1 Like