Learn Accessibility by Building a Quiz - Step 15

Tell us what’s happening:
Describe your issue in detail here.
r code so far**
Hi Maeve Brophy here. I am stuck on step 15.
I have inserted <section region="role> I am getting a message to say my code didn’t pass. Please help. Regards Maeve

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <meta name="description" content="freeCodeCamp Accessibility Quiz practice project" />
    <title>Accessibility Quiz</title>
    <link rel="stylesheet" href="styles.css" />
  </head>
  <body>
    <header>
      <img id="logo" src="https://cdn.freecodecamp.org/platform/universal/fcc_primary.svg">
      <h1>HTML/CSS Quiz</h1>
      <nav>
        <ul>
          <li><a>INFO</a></li>
          <li><a>HTML</a></li>
          <li><a>CSS</a></li>
        </ul>
      </nav>
    </header>
    <main>

<!-- User Editable Region -->

      <form method="post" action="https://freecodecamp.org/practice-project/accessibility-quiz">
      <section region="role"></section>
        <section></section>
        <section></section>
      </form>

<!-- User Editable Region -->

    </main>
  </body>
</html>

/* file: styles.css */
body {
  background: #f5f6f7;
  color: #1b1b32;
  font-family: Helvetica;
  margin: 0;
}

header {
  width: 100%;
  height: 50px;
  background-color: #1b1b32;
  display: flex;
}

#logo {
  width: max(100px, 18vw);
  background-color: #0a0a23;
  aspect-ratio: 35 / 4;
  padding: 0.4rem;
}

h1 {
  color: #f1be32;
  font-size: min(5vw, 1.2em);
}

nav {
  width: 50%;
  max-width: 300px;
  height: 50px;
}

nav > ul {
  display: flex;
  justify-content: space-evenly;
}

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.0.0 Safari/537.36 Edg/114.0.1823.51

Challenge: Learn Accessibility by Building a Quiz - Step 15

Link to the challenge:

The ‘role’ is the attribute and the “region” is its value. You have swapped them. Also, add the ‘role’ attribute and its value into all opening ‘section’ tags. Read the instruction again.

You should give this attribute to each section element not the first one only.

And as Brend said,you’ve swiped them.

Stephen
I did that and then it came back and said just apply to first section. Thank you for your help. Maeve

Hwy Silla
Can I see your code?

Thank you Stephen, for all your help with Step 15. I have got it to work out. Thank you so much. Regards Maeve

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.