Learn Advanced Bash by Building a Kitty Ipsum Translator - Build a Kitty Ipsum Translator

Tell us what’s happening:

I’m currently doing the Learn Advanced Bash by Building a Kitty Ipsum Translator and I’m on the step where I have to do You input your name, and your script output the result of the two commands. Run the script again, but use a pipe to echo your name as the input.

I’ve tried this for like the 5th time now but to no avail as it has done this:

Every time that happens, there’s a chance that it results to the same problem as reported by others where I just stay on a white screen without the virtual machine opening up (codeally doesn’t show up either).

Your code so far

I was totally lost on this part and so I pressed hint until the answer came out and did that. But before that, I tried echo <your_name> | cat

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn Advanced Bash by Building a Kitty Ipsum Translator - Build a Kitty Ipsum Translator

Link to the challenge:

I’m not sure if you still need help?
If yes, what command did you type and where did you type it?
Also what did the instructions say exactly? (please copy the exact instructions here. I was unable to see the screenshot you posted as it couldn’t be loaded in the forum for some reason)

Hi, yes! I still need help on this. :sweat_smile:

The content of my script.sh file was:


echo <your_name> | ./script.sh

This is just as the hints suggested as I ran out of ideas on how to go through this task… What I had tried to do before this was:


echo <your_name> | cat

This second one doesn’t let me go through the task.

As soon as I enter ./script.sh on the terminal using the first one, it starts lagging out and eventually disconnects from the virtual machine as you’ve seen in the picture in the original post.

*the photo that wasn’t uploaded, it says that new users can only upload up to 1 media file per post, at least that’s what I remember it said yesterday

I looked up the instructions. Actually what they said was

  • Enter echo <your_name> | ./script.sh in the terminal
  • Replace <your_name> with your name

So this echo command is supposed to be run “from the terminal”
It is not meant to be added to the shell file.

I suggest you reset (click reset) then try the command from the terminal this time.

I see :dizzy_face: I guess what I did was keep the file repeating itself, sort of or just really cause a bug that wasn’t supposed to happen.

Thank you for this clarification!

1 Like