Learn Basic CSS by Building a Cafe Menu - Step 27

Tell us what’s happening:
Hi freeCodeCamp,

I am working the exercise of CSS and I came across to a problem on line 27 in html. I’ve used the class attribute in the

element as the request, but it is appeared incorrectly, where I see also that the code is written correctly.

I would like to get some advice on this area.

Thanks.

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>Cafe Menu</title>
    <link href="styles.css" rel="stylesheet"/>
  </head>
  <body>
    <div class="menu">
      <main>
        <h1>CAMPER CAFE</h1>
        <p>Est. 2020</p>
        <section>
          <h2>Coffee</h2>
        </section>
      </main>
    </div>
  </body>
</html>
/* file: styles.css */
body {
  /*
  background-color: burlywood;
  */
}

h1, h2, p {
  text-align: center;
}

.menu {
  width: 80%;
  background-color: burlywood;
  margin-left: auto;
  margin-right: auto;
}

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.0 Safari/605.1.15

Challenge: Learn Basic CSS by Building a Cafe Menu - Step 27

Link to the challenge:

1 Like

this is correct.
What issue are you having?

HI Hbar1st,

Test: Sorry, your code does not pass, hang in there.
Tips: Your div should still render. Make sure you haven’t malformed the div tag.

As you can see the code I wrote is correct but I do not understand why does the system kept showing me this message.

Could you give some more advice on this as I might have made an issue somewhere I didn’t see.

Thanks .

Please confirm that the code above is your current code? (You haven’t changed it?)

I will test this code to see if it passes for me so just checking that it represents your current code first.

Yes, it’s my current code. :slightly_smiling_face:

Your solution works from my end. Please try one of the following steps to move forward.

Click on the “Restart Step” button and force a refresh of your page with CTRL + F5 then try to paste the code in again.

or - Try the step in incognito or private mode.

or - Disable any/all extensions that interface with the freeCodeCamp website (such as Dark Mode, Ad Blockers, or Spellcheckers), and set your browser zoom level to 100%. Both of these factors can cause tests to fail erroneously.

or - Ensure your browser is up-to-date or try a different browser.

I hope one of these will work for you.

Hi Hanaa,

Thanks for the response and my excuses for the late reply!

I have tried your method and it worked, I think surely the extension as I changed make it disabled and it worked right after.

Regards,

W. Alex Vadsoongnern

1 Like