Learn Basic CSS by Building a Cafe Menu - Step 41

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**
/* file: index.html */
<!DOCTYPE html>
<html lang="en">
  <meta charset="utf-8" />
  <meta name="viewport" content="width=device-width, initial-scale=1.0" />
  <title>Cafe Menu</title>
  <link href="styles.css" rel="stylesheet"/>
  <div class="menu">
      <h1>CAMPER CAFE</h1>
      <p>Est. 2020</p>
        <article class="item">
          <p class="flavor">French Vanilla><p class="price">3.00</p>           
          <p>Caramel Macchiato</p>
          <p>Pumpkin Spice</p>
/* file: styles.css */
body {
background-image: url(https://cdn.freecodecamp.org/curriculum/css-cafe/beans.jpg);

h1, h2, p {
text-align: center;

.menu {
width: 80%;
background-color: burlywood;
margin-left: auto;
margin-right: auto;

.item p {
display: inline-block;

.flavor {
text-align: left;
width: 49%;

.price {
text-align: right;
width: 49%;
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Challenge: Learn Basic CSS by Building a Cafe Menu - Step 41

Link to the challenge:

You are missing a closing p tag.

I have not been able to properly move forward with the assignment due to being hung up on this one code step. I’ve tried every single way possible and did what was instructed to no avail. Where am I wrong? I have done every single thing imaginable. If someone could help me with this, I’d gladly appreciate it. For anyone that would like to visually look at the code, here’s the screenshot. Thanks.

Put it back in. Still the same.

So your code looks like:

<div class="vanilla">Vanilla Bean</div><div class="money">40</div>

Ok. Where did I go wrong? Especially when I did put the closing p tag in?

You could be completely correct, what browser are you using? If your browser is out of data or you extensions are interfering with fCC it could easily throw a false fail. I would advise completely resetting the step and starting again, and if that doesn’t work try a different browser. Chrome hasn’t given me any problems.

Also you don’t have any extra < or > in there right? cuz that’ll will mess some code up.

That’s what I use and it’s been great up to this point. I’ll reset the step though and try again

Well my goodness! Resetting the step and me deleting spaces all over again worked!

Lol sometimes you just have to throw it out and try again, even with actual coding.

I see that apparently. Thank you and to everyone involved! I like this forum, especially for us rookie beginners that are learning from ground up!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.