Learn Basic JavaScript by Building a Role Playing Game - Step 93

Tell us what’s happening

Am facing a bug when building the Calorie Counter app at challenge number 37, the bug is that am not getting any challenge or any submit form or anything its only showing ny code

Your code so far

WARNING

The challenge seed code and/or your solution exceeded the maximum length we can port over from the challenge.

You will need to take an additional step here so the code you wrote presents in an easy to read format.

Please copy/paste all the editor code showing in the challenge from where you just linked.

Replace these two sentences with your copied code.
Please leave the ``` line above and the ``` line below,
because they allow your code to properly format in the post.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36

Challenge Information:

Learn Basic JavaScript by Building a Role Playing Game - Step 93

Hi there, I see you are in the advanced stages of the challenge, owing to that the code may have grown too big for you to copy/paste, perhaps it’s best you provide your relevant code (preferably perhaps the code you wrote for that challenge, leave the previous challenge code).

Additionally, I see that the code is split into three parts(html, css and js respectively) with the challenge on the right, can you not see the challenge box on the right ?

Welcome to the community!

Unfortunately, the code was too long to enter this way.

Please either use the preformatted </> option at the top of the text box, or place three ``` before and after each complete set of code?

Please include the question, as you have done here, with the new post?

Wishing you great progress!

1 Like

Hi thank you @anon42932716 and @kinzinzombe ,

The issue is that when i click on the challenge am supposed to solve next, it doesn’t give me the challenge it just shows my 21 lines of javaScript code that i have already worked on , on my previous challenges and i can’t access the forum using my laptop since am not getting the text box, luckily i had installed the free code camp forum application on my mobile device

Okay Brighton, so you’ve already solved this challenge, correct ? And you are unable to move on to the next one ?

I solved challenge 36 and when i move on to challenge 37, it doesnt show the steps to follow in order to solve that challenge, in the sense that it’s not giving me any challenge to solve.

1 Like

This may be an issue with freecodecamp, I am getting the same error as you, is the “Check your code” button working on your end ?

1 Like

Yahh i think soo too, as for me i dont even have that "Check your code " button .

1 Like

I was really looking forward to finishing form validation project tonight.

1 Like

I created an issue here:

I’m sure someone in the community will resolve the issue by tomorrow, you can rest for today

Hi thanks a lot for your effort, much appreciated but why is it saying role playing game and challenge 93, because am working on the Form validation by building a calorie counter app challenge 37. Thats the one giving me issues, i finished the role playing game yesterday

1 Like

Looking back a few weeks back when i was starting freecode camp i opened up a topic when i was stuck on the first project the role playing game but i never posted that topic so now that i opened up a topic using my phone it must have automatically went to my drafts and used the one that i had opened when i was first starting free code camp and am sorry for that.

I have rebooted my machine and refreshed the browser but am still not getting a challenge on the form validation project challnge number 37

Yes, that’s correct.

I would very much appreciate it, hope am not being too much of a troublesome?

If you are not seeing the challenge steps its a known issue. Try clearing your cache, or trying a different browser

2 Likes

Thank you let me try clearing my cache.

1 Like