This is not correct, and the challenge is correctly rejecting this code.
The song variable is already declared and cannot be re-declared.
You need to use the song variable that’s already there and assign its value to the userData.currentSong. (or to say it another way, your use of = is “backwards”)
Start by accessing the userData object and its currentSong property. Set its value equal to the song variable.
I might say it like this instead.
Assign song to the currentSong property on the userData object
Seems a lot more straight forward
Accessing a property implies reading, more than writing. Sure, you are then told to “set its value” but the sentence is harder to read than it has to be.