learn.freecodecamp.org’s server IP address could not be found

learn.freecodecamp.org’s server IP address could not be found
0.0 0

#1

I’ve been using a VPN for a few months now and have been able to complete lessons on FCC. However, in the last week (since June 22nd at least), I am no longer able to access learn.freecodecamp.org, support.freecodecamp.org, beta.freecodecamp.org, or even https://maintenance-page.freecodecamp.org. This seems random and I’m not sure what the problem is. I’ve tried on multiple browsers, have flushed my DNS, and have cleared my cache, but the issue still remains. Again, this is new. I haven’t had any issues prior to this past week.

I am aware that one option is “Turn off your VPN”, but before I do anything close to giving up my privacy I want to see what other options there are.

I’ve included an example screenshot for your reference. Any input or comments, especially if someone else is experiencing this, is greatly appreciated.

image


#2

Where is the IP address being routed via at the times you lose access (if the answer is ‘Russia’ then not it’s not super surprising you get blocked)?


#3

I’ve tried multiple places. Several US servers, France, Austria, Canada, and it still doesn’t work. I’m going to add the VPN to my phone and see if I can access it that way to test if the issue is my computer or VPN.


#4

I’ve tested the website with the VPN on my phone and can bring up my most recent lesson. I then tried to access the lesson directly instead of trying to go through freecodecamp.org or learn.freecodecamp.org and it just sits continuous trying to load but never does. (Still going as of right now after 45 minutes.) My VPN for my computer is currently in the US while my phone is in France. Very bizarre. Again, this is a recent development.