Learn HTML by Building a Cat Photo App - Step 12

Tell us what’s happening:
Describe your issue in detail here.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->

<!-- User Editable Region -->

      <p>See more cat photos in our gallery.cat photos</p>
      <a> href="https://freecatphotoapp.com".link to cat pictures</a>


<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/111.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 12

Link to the challenge:

Anyone can help me? I stop in coding on step 12. I want to be a good programmer.

Welcome to the forum!
I suggest reviewing the step 11, just completed by you. The process is the same with the exception that only the words ‘cat photos’ will be anchored within the ‘a’ element.
For example only:
The bright red < opening anchor > sports car < closing anchor > won the race.

I hope this helps you. Happy coding! :slight_smile:

You are required to turn some texts within the paragraph element at line 7 into a link.

Again, I discovered that you have modified the code in line 8 from its original correct code to a wrong one. Kindly look very well and you will see it.
Happy coding…

1 Like
  <p>
  <a
  href="https://freecatphotoapp.com>">
  </a>
  </p>

Now I change the code to this way. The hint indicate that href value should be https://freecatphotoapp.com . you have either omitted the href value or have a typo.
I think the website name I do not type wrong. My problem is about having a typo.
I don’t know how to solve it.

 <p>
  <a
  href="https://freecatphotoapp.com>">
  </a>
  </p>

Now I change the code to this way. The hint indicate that href value should be https://freecatphotoapp.com . you have either omitted the href value or have a typo.
I think the website name I do not type wrong. My problem is about having a typo.
I don’t know how to solve it.

The sample code you provided still have some typos and you have not wrapped the anchor tag around the texts the instruction asked you to do.

Please kindly reset that particular task, start it afresh, and read the instructions carefully and you will figure it out.

What the task wants you to do is very similar to what you did in STEP 11

:slight_smile: Please review the steps you took to complete Step 11? This step is the same except the words ‘cat photos’ is being anchored. Only anchor the words cat photos in the p element. Do not make any other changes.
Also, I would suggest following the instructions of CNwante as to resetting and starting anew with the step. That way all the mistakes will be cleared and your fresh steps should work.
Happy coding!:slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.