Learn HTML by Building a Cat Photo App - Step 12

Tell us what’s happening:
I can’t figure out what I am doing wrong on this step it wont run

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->

<!-- User Editable Region -->

      <p>See more <a>cat photos</a> in our gallery.</p>
      <a href="https://freecatphotoapp.com">linnk to cat pictures</a>

<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36 Edg/116.0.1938.69

Challenge: Learn HTML by Building a Cat Photo App - Step 12

Link to the challenge:

You need to tell the browser where the link should go to by adding the href attribute. See the link you created below the p element for an example.

Also, don’t make any extra changes that the instructions did not ask you to make, such as adding an extra n in the work link.

Even the smallest unexpected change can cause the tests to fail.

I must be doing something wrong please kindly provide the solution as I have been stuck on this step for the past days

See more <a href="cat photos" in our gallery.

link to cat pictures

We don’t provide solutions in here. You were very close. As I mentioned, you forgot to add the href attribute to the opening a tag.

<a>cat photos</a>

This link doesn’t have an href attribute so the browser won’t know where to go when you click on it. You need to add the href attribute.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.