Learn HTML by Building a Cat Photo App - Step 12

Tell us what’s happening:
Describe your issue in detail here.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->

<!-- User Editable Region -->

      <p> cat photos<a href="https://freecatphotoapp.com"</a>See more cat photos in our gallery.</p>
      <a href="https://freecatphotoapp.com">link to cat pictures</a>

<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/117.0.0.0 Safari/537.36 Edg/117.0.2045.47

Challenge: Learn HTML by Building a Cat Photo App - Step 12

Link to the challenge:

You don’t want to add any new text to the p element. I would reset the step to get the original HTML back.

The only thing you want to do is turn the words “cat photos” in the middle of the p element into a link. You have already turned the words “link to cat pictures” into a link in previous steps. Look at how you did that. You did that by wrapping them in an anchor element. In other words, you put an opening a tag before the words and a closing a tag after the words. You need to do the same thing to the words “cat photos” in the middle of the p element.

In the <p element, you have a tag error in the link part. The opening <a tag has a closing sign before the URL and the closing <a tag is missing

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.