Learn HTML by Building a Cat Photo App - Step 12

Tell us what’s happening:

Describe your issue in detail here.

I am stuck at step 12. I don´t understand what is wrong with my coding.
This is what i have written:

See more cat photos in our gallery.


link to cat pictures

And it say this: The link’s href value should be https://freecatphotoapp.com . You have either omitted the href value or have a typo.

What??

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

Hello and Welcome!

Could you please post the complete HTML code for review.

Without seeing the complete code, we are not sure what is happening and why you are receiving the error message.

Using three ``` back ticks before and after the code will allow you to copy and paste it here.

Thank you!

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->

<!-- User Editable Region -->

      <p>See more <a>cat photos</a> in our gallery.</p>
      <a href="https://freecatphotoapp.com">link to cat pictures</a>

<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 12

It appears the anchor attribute and its value are missing from the code.

I suggest using the anchor below as reference to enter the href and its value url.

I hope this helps you.

Wishing you good progress.

Hm no sorry, i dont understand what you mean?
Where am i wrong?

you can tell im new at this…

the first task “turn cat photos into a link” is correct or no?

It’s the second row that’s wrong? I’ve tried so many options and i dont get it right!

I have done exactly like the example in the question now, but it’s still wrong?

This is what i have written:

  <p>See more <a href="https://freecatphotoapp.com">cat photos<a/> in our gallery.</p>
1 Like

closing tag does not look right

2 Likes

omg, yes! Thank you, i finally got i right now :sweat_smile:

1 Like

Your first exposure is hard, it gets better I promise. Some of the things I could not understand I can now recall without prompting, like how to tag and anchor a link. You will progress faster if you take it upon yourself to highlight the question and google it; there will be many post you will have to decide which to look at but it is how I solved 90% of my sticking points. and I was late discovering how helpful the ChatGPT https://chat.openai.com , like having your own tutor sitting there. plug the question it, it breaks it down for you and provides reference to sites where elements and such are broken down and described in detail, site such as https://www.w3schools.com, https://developer.mozilla.org these 2 sites i had pinned to the browser for some time and references them constantly. Save posting here for real sticking points and clarification when the answer is right but you dont know why it is right. Unlike the conventional wisdom of finding the answer the hard way, for many things it is much easier for me to understand and retain if i see the right answer and deduce from there But codecamp erases answers like that when given and have scrubbed the internet of them in some cases. I hope this helps!

P.S. When it really looks right and youve changed it a few times and stuck, take a real hard look digit by digit, letter by letter and you will find a spelling error. I used to go nuts until I started working this in as the first step to solving the problem lol. ALSO…sometimes cutting and pasting will get you in trouble; for whatever reason, the terminal doesnt like it sometimes and will kick it regardless. you must scrap it and type it all or CP again and it will work. this has happened 20 times to me at least.

1 Like

a little hit of Dopamine, right? lol.

Haha I stared at the screen for ages and thought I was going crazy for not getting it.
Thank you for your tips!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.