Learn HTML by Building a Cat Photo App - Step 12

Tell us what’s happening:

Describe your issue in detail here.
my code seems to have all elements but not working

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->

<!-- User Editable Region -->

      <p>See more <a href="cat photos">in our gallery.</a></p>
      <a href="https://freecatphotoapp.com">link to cat pictures</a>

<!-- User Editable Region -->

      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/109.0.0.0 Safari/537.36

Challenge Information:

Learn HTML by Building a Cat Photo App - Step 12

You appear to have created this post without editing the template. Please edit your post to Tell us what’s happening in your own words.
Learning to describe problems is hard, but it is an important part of learning how to code.
Also, the more you say, the more we can help!

Welcome to the forum @glenn1

Just a fix things to fix up.

  1. the href attribute value needs to be the web address given in the instructions, not the words cat photos
  2. the words cat photos go after the opening anchor tag
  3. place the closing anchor tag after the word photos
  4. leave a single space between the closing anchor tag and the word in

Happy coding