Learn HTML by Building a Cat Photo App - Step 14

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**
<html>
<body>
  <h1>CatPhotoApp</h1>
  <main>
    <h2>Cat Photos</h2>
    <!-- TODO: Add link to cat photos -->
    <p>Click here to view more cat photos.</p>
    <a href =" https://freecatphotoapp.com"> 
      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
    </a>
  </main>
</body>
</html>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36 Edg/105.0.1343.33

Challenge: Learn HTML by Building a Cat Photo App - Step 14

Link to the challenge:

You have a space that shouldn’t be there.

I fixed it but I still get a message that my anchor element should have an opening tag

Did you change anything other than removing the space in the URL?

This should be your code now.

<a href="https://freecatphotoapp.com"> 
  <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
</a>

If that doesn’t work, copy the code and restart the step. Paste it back in and see if it passes.

That’s exactly how I had the code, but it wasn’t working. After I repasted it, the exact same way, I was able to continue. I don’t know what was causing the error, but I got it now thanks.

Sometimes it is worth restarting the step. It can get into an odd state where it doesn’t pick up the latest code.

have you tried to restart the step? and then not adding the extra space