Learn HTML by Building a Cat Photo App - Step 15

Tell us what’s happening:
I’m stuck on this step. I can’t figure out what’s going wrong or where in the line I should put the <a.

Your code so far

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
      <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."> <a href='https://freecatphotoapp.com'</a>
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

hi there,

when you want to make a link (whether it is a word or an element), you should place the opening tag of the anchor element on the left of the word or element (or img) and place the closing tag on the right hand side of the word/element/img

Make sure you are creating valid HTML code (refer to step 10 and 11 if needed)

hello and welcome to fcc forum :slight_smile:

  • your “anchor” tag has a syntax error, it’s missing “closing” bracket for it’s “opening” tag

also as “hbar1st” pointed out, “img” tag needs to be “nested” within this “anchor” tag, as per instructions (i.e. <a> <p></p> </a>)

address these changes it should be alright, happy learning :slight_smile: