Learn HTML by Building a Cat Photo App - Step 15

help please

<html>
  <body>
    <main>
      <h1>CatPhotoApp</h1>
      <h2>Cat Photos</h2>
      <!-- TODO: Add link to cat photos -->
      <p>Click here to view more <a target="_blank" href="https://freecatphotoapp.com">cat photos</a>.</p>
    <a> href="https://freecatphotoapp.com">
      img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg"<>
      </a>
      
    </main>
  </body>
</html>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36

Challenge: Learn HTML by Building a Cat Photo App - Step 15

Link to the challenge:

Please Tell us what’s happening in your own words.

Learning to describe problems is hard, but it is an important part of learning how to code.

Also, the more you say, the more we can help!


This is not a valid opening img tag

You changed the img tag to invalid syntax.

well i tried my best to make the image into a link and tried multiple method after a lot of error and its been like 30 min since im on this problem.

what should i do then

You should

  1. Write a valid opening anchor tag instead of an invalid one. The line above (the p element) has a valid anchor element.

  2. Do not break the img element. Make zero changes to the img element.

<a href="https://freecatphotoapp.com" <img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back."</a>
i thought doing it like this would work but i dont see where is the problem

This is still not a valid opening anchor tag. Every tag must have < and >

You changed the img tag. You should not delete any part of the img tag. Every tag must have < and >

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.